December 06, 2019, 02:45:43 AM

Author Topic: [Fixed] - Red text?  (Read 2426 times)

Offline JungleDev

  • Level 0 Beginner
  • Posts: 12
  • Country: 00
  • <3 WCS :)
[Fixed] - Red text?
« on: November 02, 2014, 01:26:16 AM »
I know this will sound weird, but all of sudden my WCS kind of restarted by itself (I warned you), and now all the text that should be #lightgreen is red?! YES it's weird. I did not install any chat addons or anything. Anyone ever seen something like that?
« Last Edit: November 02, 2014, 03:36:41 PM by Manifest »

Offline Manifest

  • Race & effect creator
  • Moderator
  • Level 7 Expert
  • *****
  • Posts: 1063
  • Country: dk
  • Content creator for the new WCS version by Kami.
Re: Red text?
« Reply #1 on: November 02, 2014, 11:04:28 AM »
Hello again Jungle  :)

Never while playing around with WCS have I ever experienced something like this.
If you haven't tried it already then try restarting the server, or do a clean reinstall, that is probably my best suggestion on how you can fix this. It sounds quite wierd though :p

Sincerely
- Manifest
"BRAVORA: Bruh it is fucking operation crystal night when you are approving races."


Offline Existenz

  • Level 4 Intermediate
  • ****
  • Posts: 87
  • Country: fr
  • <3 WCS :)
Re: Red text?
« Reply #2 on: November 02, 2014, 11:29:56 AM »
You just have to go in the colors.ini, in _libs\python\esc and look if the color lightgreeen seems to that :

Code: [Select]
"#lightgreen" = 155, 255, 155
And red is that :

Code: [Select]
"#red" = 255, 61, 61
There was a small reversal in color .

Offline Manifest

  • Race & effect creator
  • Moderator
  • Level 7 Expert
  • *****
  • Posts: 1063
  • Country: dk
  • Content creator for the new WCS version by Kami.
Re: Red text?
« Reply #3 on: November 02, 2014, 11:33:21 AM »
You just have to go in the colors.ini, in _libs\python\esc and look if the color lightgreeen seems to that :

Code: [Select]
"#lightgreen" = 155, 255, 155
And red is that :

Code: [Select]
"#red" = 255, 61, 61
There was a small reversal in color .

Nice work man, I wasn't even aware of these changes!
Nicely spotted :)

Sincerely
- Manifest
"BRAVORA: Bruh it is fucking operation crystal night when you are approving races."


Offline Existenz

  • Level 4 Intermediate
  • ****
  • Posts: 87
  • Country: fr
  • <3 WCS :)
Re: Red text?
« Reply #4 on: November 02, 2014, 12:05:04 PM »
I already had this problem , so I look in the colors.ini and I saw this little mistake ^^

Offline Manifest

  • Race & effect creator
  • Moderator
  • Level 7 Expert
  • *****
  • Posts: 1063
  • Country: dk
  • Content creator for the new WCS version by Kami.
Re: Red text?
« Reply #5 on: November 02, 2014, 12:22:41 PM »
I already had this problem , so I look in the colors.ini and I saw this little mistake ^^

Wow, it's quite wierd though, I have never heard of this bug before nor encountered it. But hey, if it works out then you should totally post a bug fix thread here on the forum, I bet more people will need the solution later on :)
Can I ask what versions of eventscripts and WCS you are running by the way? :)

Sincerely
- Manifest
"BRAVORA: Bruh it is fucking operation crystal night when you are approving races."


Offline Existenz

  • Level 4 Intermediate
  • ****
  • Posts: 87
  • Country: fr
  • <3 WCS :)
Re: Red text?
« Reply #6 on: November 02, 2014, 01:02:00 PM »
I think it was fixed and the problems came from colors.ini provides the wcs.

Offline JungleDev

  • Level 0 Beginner
  • Posts: 12
  • Country: 00
  • <3 WCS :)
Re: Red text?
« Reply #7 on: November 02, 2014, 03:15:22 PM »
Hello again Jungle  :)

Never while playing around with WCS have I ever experienced something like this.
If you haven't tried it already then try restarting the server, or do a clean reinstall, that is probably my best suggestion on how you can fix this. It sounds quite wierd though :p

Sincerely
- Manifest

Yeah I really tried restarting the server a bunch of times.

You just have to go in the colors.ini, in _libs\python\esc and look if the color lightgreeen seems to that :

Code: [Select]
"#lightgreen" = 155, 255, 155
And red is that :

Code: [Select]
"#red" = 255, 61, 61
There was a small reversal in color .

This fixed it! Whoa, this was quite unexpected. Thank you all for the help!

Offline Kamiqawa

  • Watchdog
  • Level 7 Expert
  • *****
  • Posts: 784
  • Country: fi
Re: [Fixed] - Red text?
« Reply #8 on: November 06, 2014, 05:30:55 PM »
Yeah, it is a common error related to esc module; the module has predefined colors in colors.ini and there is a mistake of greem having the red value instead. Easily fixed by flipping those r and g values of rgb around.
Want your own custom color for your forum username? No worries! La Muerte is here ready to fulfill your every rainbow-colored wish!

As a special offer of the day you can go talk with Tha Pwned first, and come ahead of the line!

I AM PINK!